Page 1 of 1

CLASSPATH issue (yet again?), MAC OS X 10.6

Posted: Tue 7. Feb 2012, 01:25
by fvogt
Hi everyone,

I installed jReality following the instructions on the website point-to-point (http://www3.math.tu-berlin.de/jreality/ ... t-tutorial).
All works fine, however, when I try to launch it, I get :

Code: Select all

2012-02-07 $ java jReality.jar 
Exception in thread "main" java.lang.NoClassDefFoundError: jReality/jar
Caused by: java.lang.ClassNotFoundException: jReality.jar
	at java.net.URLClassLoader$1.run(URLClassLoader.java:202)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.net.URLClassLoader.findClass(URLClassLoader.java:190)
	at java.lang.ClassLoader.loadClass(ClassLoader.java:306)
	at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:301)
	at java.lang.ClassLoader.loadClass(ClassLoader.java:247)
From what I gathered on the website, this looks like a CLASSPATH issue. I subsequently tried to update CLASSPATH with :

Code: Select all

 export CLASSPATH=$CLASSPATH:\my_path/jr_release/jr/lib/whatever.jar:etc...
But no success. I also tried directly :

Code: Select all

 java -classpath \my_path/jr_release/jr/lib/whatever.jar:etc... jReality.jar 
Still no success. Can't figure out what's wrong - but have the feeling that it might be an obvious mistake ...
MAC OS X 10.6, Java JDK 10.6, java newbie. Any help greatly appreciated.

Fr├ęd

Re: CLASSPATH issue (yet again?), MAC OS X 10.6

Posted: Wed 8. Feb 2012, 05:52
by fvogt
Problem solved. All it took was installing eclipse - see these instructions :

http://www3.math.tu-berlin.de/jreality/ ... p_tutorial

Re: CLASSPATH issue (yet again?), MAC OS X 10.6

Posted: Wed 8. Feb 2012, 10:46
by Andre
Hi fvogt,

welcome to jReality.

If you want to run jReality via terminal you have to unzip the jni-folder for your operating system. This should be the jReality-jni-macosx.zip in your case. You have to add these "pre-compiled" libs to your classpath aswell.

Using Eclipse is of course the easier way.

Have Fun
Andre