Page 1 of 1

setPerspective(false) doesn't work with softviewer

Posted: Thu 19. Mar 2009, 21:32
by Joe
The non perspective camera mode works only with the JOGL renderer, not with the softviewer. You can reproduce it like this:

* Start the ViewerApp (WebStart)
* Activate the JOGL viewer by hitting F1
* Load a geometry file (I loaded a 3DS file)
* Open nodes in Navigator: Avatar, cameraNode, camera and set "perspective" to "false".
* Activate the viewer window: The geometry changes to parallel projection.
* Change back to perspective mode
* Change to softviewer
* Set "perspective" to "false" and activate the viewer window.
=> The geometry doesn't change. When you try to rotate it, something strange happens.

My system: Windows XP Professional, SP 3; Java Plug-in 1.5.0_16

Posted: Tue 24. Mar 2009, 18:52
by timh
sorry, I can not reproduce this here at the moment (mac, java 1.6):
I tried different ways to switch between software viewer and jogl and perspective true or false and allways got matching views for jogl and software rendering.
Does the behaviour happen, when changing to perspective=false and then from jogl to software rendering?

best
Tim

Posted: Tue 24. Mar 2009, 19:48
by Joe
I can reproduce it even with jre1.6.0_02.

When I start ViewerApp from the start page of www.jreality.de, the viewer starts with JOGL. I load a 3DS file (not a scene), switch to perspective = false (by clicking in navigator: avatar, cameraNode, camera) and click the title of the viewer window, to give the focus back. In this moment, the model is rendered in non perspective mode. If I now switch to the softviewer, the model disappears. It comes back, if I change back to JOGL.

I hope you can reproduce it under Windows. Maybe the Mac-JRE has a different behavior?

Posted: Thu 26. Mar 2009, 11:11
by gunn
It may be that the webstart for ViewerVR on the home page is out of date! Better to experiment with the current svn version. The class de.jreality.vr.ViewerVR has a main method that you can run. Make sure that you've got vrExamples.jar and vrData.jar in your class path, however, so the textures and models are available.

Posted: Thu 26. Mar 2009, 20:42
by Joe
Even with the current version (2009-03-13), the problem occurs. Can you reproduce it with Windows?

Posted: Sat 11. Apr 2009, 22:08
by Joe
I asked a friend with a Mac. He also could reproduce the problem. After switching to non perspective mode with the soft viewer, the camera seems to be placed into the model, instead of viewing it completly.

Posted: Thu 23. Apr 2009, 22:28
by Joe
Can somebody of the jReality team reprocude this with Windows or another Mac?

Posted: Wed 29. Apr 2009, 21:10
by timh
Hi,
I commited two changes to the svn repository now: One that ensures that changing the camera settings will trigger a render so that changes become visible immediately (in both jogl and soft viewer).
The second one fixes the problem, that the softviewer does not show any content in the first render after a change of the perspective setting. On my mac, jogl and soft viewer render identical views now even when switching back and forth between them and perspective modes.

Can someone, who could reproduce the problem please check wether it is gone now?

Best
Tim

Posted: Thu 30. Apr 2009, 06:48
by Joe
Hi,
now it works. Many thanks for this fix / change.

Best regards, Joe