Page 1 of 1

Jogl Viewer Texture Bug

Posted: Fri 18. Oct 2013, 17:00
by sechel
Hi, this is probably for Charles: I have problems using textures. If I change the texture image of a geometry a few times or if I show frequently changing lables. I run into the following Exception pretty soon:

Code: Select all

java.lang.reflect.InvocationTargetException
	at java.awt.EventQueue.invokeAndWait(EventQueue.java:1272)
	at java.awt.EventQueue.invokeAndWait(EventQueue.java:1247)
	at de.jreality.jogl.AbstractViewer.render(AbstractViewer.java:570)
	at de.jreality.ui.viewerapp.ViewerSwitch.render(ViewerSwitch.java:191)
	at de.jreality.util.RenderTrigger$RenderTriggerSingleCaster.render(RenderTrigger.java:239)
	at de.jreality.util.RenderTrigger.fireRender(RenderTrigger.java:155)
	at de.jreality.util.RenderTrigger.finishCollect(RenderTrigger.java:277)
	at de.jreality.toolsystem.ToolSystem.processToolEvent(ToolSystem.java:486)
	at de.jreality.toolsystem.ToolEventQueue$1.run(ToolEventQueue.java:82)
	at java.lang.Thread.run(Thread.java:724)
Caused by: java.lang.NullPointerException
	at jogamp.opengl.gl4.GL4bcImpl.glDeleteTextures(GL4bcImpl.java:3892)
	at de.jreality.jogl.shader.Texture2DLoaderJOGL.render(Texture2DLoaderJOGL.java:206)
	at de.jreality.jogl.shader.Texture2DLoaderJOGL.render(Texture2DLoaderJOGL.java:142)
	at de.jreality.jogl.JOGLRendererHelper.renderLabels(JOGLRendererHelper.java:825)
	at de.jreality.jogl.JOGLRendererHelper.drawPointLabels(JOGLRendererHelper.java:753)
	at de.jreality.jogl.JOGLPeerGeometry.render(JOGLPeerGeometry.java:98)
	at de.jreality.jogl.JOGLPeerComponent$1.run(JOGLPeerComponent.java:129)
	at de.jreality.scene.Scene.executeReader(Scene.java:81)
	at de.jreality.jogl.JOGLPeerComponent.preRender(JOGLPeerComponent.java:195)
	at de.jreality.jogl.JOGLPeerComponent.render(JOGLPeerComponent.java:148)
This is very annoying as one has to restart the program after such an exception to continue working with textures. The machine which I'm working on is:

Hardware-Übersicht:

Modellname: MacBook Pro
Modell-Identifizierung: MacBookPro10,2
Prozessortyp: Intel Core i7
Prozessorgeschwindigkeit: 2,9 GHz
Anzahl der Prozessoren: 1
Gesamtanzahl der Kerne: 2
L2-Cache (pro Kern): 256 KB
L3-Cache: 4 MB
Speicher: 8 GB

Intel HD Graphics 4000:

Chipsatz-Modell: Intel HD Graphics 4000
Typ: GPU
Bus: Integriert
VRAM (gesamt): 768 MB
Hersteller: Intel (0x8086)
Geräte-ID: 0x0166
Versions-ID: 0x0009
Monitore:
CE240W:
Auflösung: 1920 x 1200
Pixeltiefe: 32-Bit Farbe (ARGB8888)
Monitor-Seriennummer: 31653127
Hauptmonitor: Ja
Synchronisierung: Aus
Eingeschaltet: Ja
Rotation: Unterstützt

Re: Jogl Viewer Texture Bug

Posted: Mon 28. Oct 2013, 13:50
by gunn
I have had some problems related to textures on my relatively new Macbook Pro recently which I solved by backing out changes to the jreality jogl package to mid-summer. Please try that first.

Then if you still have the problem, please try to isolate example code that displays the problem. I'm not seeing this error in the code I'm running right now.